align-toparrow-leftarrow-rightbackbellblockcalendarcamerachatcheckchevron-downchevron-leftchevron-rightchevron-small-downchevron-small-leftchevron-small-rightchevron-small-upchevron-upcircle-with-crosscrosseditemptyheartfacebookfullheartglobegoogleimagesinstagramlocation-pinmagnifying-glassmailmoremuplabelShape 3 + Rectangle 1outlookpersonplusImported LayersImported LayersImported Layersshieldstartwitteryahoo

Auckland Magento User Group Message Board › Magento upgrade from 1.4

Magento upgrade from 1.4

Rian H.
user 13010893
Sydney, AU
Post #: 8
I've finally taken it upon myself to upgrade my magento past 1.4.1.1

I've sorted everything out themes and all that stuff. Magento connect works ! Yay!

But the big question is moving my database over.

I take it it's not as simple as just changing the local.xml to point to the old db.

If anyone can point me in the right direction where to start that would be great.

Oh btw sadly I have no SSH on my hosting.

Thanks once again.

Rian
Robert
user 4396114
Auckland, NZ
Post #: 7
If you performed the upgrade on a test site, then the steps would be:

1. Take the live site down (best to do a .htaccess redirect to a maintenance page but exclude your IP so you can work with the site)
2. Important: take a backup of all site files AND the live database AFTER taking it down.
3. Move your fixed theme files and any updated extensions, etc. to the live site via FTP
4. Perform the magento upgrade via Magento Connect on live
5. Test the admin functionality and front end for any issues
6. Remove the .htaccess restrictions to open your site up for business.

Note that if you find that you need to restore your backup because your upgrade didn't work, then make sure you drop the database, re-create it and then restore the backup DB. Otherwise your next upgrade attempt will most likely fail.
Rian H.
user 13010893
Sydney, AU
Post #: 9
By backup the database you mean via magento backup or via MySQL ?

Can you upgrade 1.4.1.1 to 1.6 via connect ? I didnt think you could ????

So in short what your saying is.......

Backup db
Drop db in new and import old db to new
Delete localxml and reinstall magento

Correct ?

Thanks once again

Robert
user 4396114
Auckland, NZ
Post #: 8
You may need to explain how exactly you fixed your templates as mentioned in your first post.

Essentially, you have your live site running 1.4.1.1 with its DB.

On the other side, presumably somewhere you have updated code that you made sure will run with 1.6.2. This part is unclear from your first post. But if you do, then you will need to transfer that to the live site. If you do want to use Magento Connect to upgrade, you should only transfer non-core files like theme / skin / local / community extensions. Then you can go to Connect Manager and get the Mage_All_Latest meta package if not already installed. That one will upgrade any other core packages. Note that the current stable release is 1.7.0 so you will be getting upgraded to this if you use this approach.

It seems it's best for you to google "Magento upgrade" and read some posts around various strategies. It's difficult to guide you with little information about your situation.

BTW, when upgrading, you never reinstall Magento. What happens when you replace a DB from an older version of Magento into a newer version, Magento will detect that and automatically run all the upgrade scripts on that old DB and you end up with the upgraded site.
Rian H.
user 13010893
Sydney, AU
Post #: 10
Hi Robert,

Thanks for the Reply.

Here is where im up to.........

Ive installed a fresh install of Magento 1.7 and have copied over my 3x themes I use from my 1.4 and also removed all my previous packages from 1.4 as I will just reinstall them all under 1.7.

Everything is working fine on 1.7 however Im trying to get my DB from 1.4 into 1.7 which i'm having a little luck with.

If I install a new DB then try to import my 1.4 DB into it I get this error.

Error

SQL query:

CREATE TABLE `admin_user` (
`user_id` mediumint( 9 ) unsigned NOT NULL AUTO_INCREMENT ,
`firstname` varchar( 32 ) NOT NULL default '',
`lastname` varchar( 32 ) NOT NULL default '',
`email` varchar( 128 ) NOT NULL default '',
`username` varchar( 40 ) NOT NULL default '',
`password` varchar( 40 ) NOT NULL default '',
`created` datetime NOT NULL default '0000-00-00 00:00:00',
`modified` datetime default NULL ,
`logdate` datetime default NULL ,
`lognum` smallint( 5 ) unsigned NOT NULL default '0',
`reload_acl_flag` tinyint( 1 ) NOT NULL default '0',
`is_active` tinyint( 1 ) NOT NULL default '1',
`extra` text,
PRIMARY KEY ( `user_id` ) ,
UNIQUE KEY `UNQ_ADMIN_USER_USERNAME` ( `username` )
) ENGINE = InnoDB AUTO_INCREMENT =6 DEFAULT CHARSET = utf8 COMMENT = 'Users

If I install the 1.4 DB first then run an install it works but I have numerous errors on different things regarding the differences between 1.4 and 1.7 but the site seems to work but I think these errors will turn into bigger errors further down the track as I can even change a theme without errors.

Ive found a few bits of information regarding install but nothing seems to work or is a definitive answer on how to upgrade from 1.4 to 1.7

Thanks foir your help and advice


Powered by mvnForum

Our Sponsors

  • Lero9

    LERO9 provide the space for the Magento Meetups.

  • Fooman

People in this
Meetup are also in:

Sign up

Meetup members, Log in

By clicking "Sign up" or "Sign up using Facebook", you confirm that you accept our Terms of Service & Privacy Policy