addressalign-toparrow-leftarrow-rightbackbellblockcalendarcameraccwchatcheckchevron-downchevron-leftchevron-rightchevron-small-downchevron-small-leftchevron-small-rightchevron-small-upchevron-upcircle-with-checkcircle-with-crosscircle-with-pluscrossdots-three-verticaleditemptyheartexporteye-with-lineeyefacebookfolderfullheartglobegmailgoogleimageimagesinstagramlinklocation-pinmagnifying-glassmailminusmoremuplabelShape 3 + Rectangle 1outlookpersonplusprice-ribbonImported LayersImported LayersImported Layersshieldstartickettrashtriangle-downtriangle-uptwitteruseryahoo

Re: [dotnet-120] ASP.NET MVC / Entity Framework / Membership

From: Sergey L.
Sent on: Saturday, August 15, 2009 9:24 PM
Kevin,

This seems to be an assembly loading problem rather than anything  
specific to ASP.NET. Try removing the second comma and everything  
after it in the type attribute (don't specify assembly version etc.).  
If it doesn't help, search MSDN on how to enable Fusion Loader  
logging, enable it, and use this log to find out why the assembly is  
not loading.
HTH,

Sergey.

On Aug 14, 2009, at 11:04 AM, Kevin Slesinsky <[address removed]>  
wrote:

> Hello. Is anyone working with ASP.NET MVC combined with Entity
> Framework? I'm looking for others to chat with about it.
>
> Specifically, right now I'm implementing Authentication, trying out
> these providers:
>
> http://www.codepr...­
>
> I created a new project, a new EDM, and copied the
> EFMembershipProvider­ class (in a folder called Security), modifying
> the namespace appropriately for my project:
> MvcTestMembership.Se­curity.  I also copied and modified the
> ProviderUtils.cs file.
>
> I went to set up the web.config ...
> <membership defaultProvider="EFM­embershipProvider" ....
> ...
> <add name="EFMembershipPr­ovider"
> type="MvcTestMembers­hip.Security.EFMembe­rshipProvider,
>              MvcTestMembership, Version=[masked], Culture=neutral,
>              PublicKeyToken=53fb0­8796b3f3bb2" ...
>
> Also put in the <machineKey ...> setting as well.
>
> When I went to test out logging in, I got a Configuration Error:
> Could not load file or assembly 'MvcTestMembership, Version=[masked],
> Culture=neutral, PublicKeyToken=53fb0­8796b3f3bb2' or one of its
> dependencies. The located assembly's manifest definition does not
> match the assembly reference. (Exception from HRESULT: 0x[masked])
>
> I did try removing MvcTestMembership from the type string, but got the
> error, "The given assembly name or codebase was invalid."
>
> Any ideas?
> Kevin
>
>
>
>
> --
> Please Note: If you hit "REPLY", your message will be sent to  
> everyone on this mailing list ([address removed])
> http://www.meetup...­
> This message was sent by Kevin Slesinsky ([address removed]) from  
> New York .NET Meetup Group.
> To learn more about Kevin Slesinsky, visit his/her member profile: http://www.meetup...­
> To unsubscribe or to update your mailing list settings, click here: http://www.meetup...­
> Meetup Support: [address removed]
> 632 Broadway, New York, NY 10012 USA

People in this
Meetup are also in:

Sign up

Meetup members, Log in

By clicking "Sign up" or "Sign up using Facebook", you confirm that you accept our Terms of Service & Privacy Policy