addressalign-toparrow-leftarrow-rightbackbellblockcalendarcameraccwcheckchevron-downchevron-leftchevron-rightchevron-small-downchevron-small-leftchevron-small-rightchevron-small-upchevron-upcircle-with-checkcircle-with-crosscircle-with-pluscrossdots-three-verticaleditemptyheartexporteye-with-lineeyefacebookfolderfullheartglobegmailgooglegroupsimageimagesinstagramlinklocation-pinm-swarmSearchmailmessagesminusmoremuplabelShape 3 + Rectangle 1outlookpersonJoin Group on CardStartprice-ribbonImported LayersImported LayersImported Layersshieldstartickettrashtriangle-downtriangle-uptwitteruseryahoo

Oklahoma Pinball Enthusiasts Message Board › My Slingshots repair thread

My Slingshots repair thread

Shawn L.
alveolus
Group Organizer
Oklahoma City, OK
Post #: 105
Yesterday at SS the afternoon went almost entirely failure free! With so many machines, that is really impressive.

There were only too minor issues observed.
1. GI is out on RBION.
2. Apollo 13 failed to launch a ball all the way up in 13 ball multiball, and then many got stuck in the shooter lane up the lane. Had to tilt them out, but at least it was recoverable.


The games played great!

Forgot to mention, on BOP I made the billion shot! I then spun the big wheel again, and relit the billions shot! I missed that second billion shot (2 billion score would have been awesome), and shortly after that the game reset. I wonder if this is related to the known billionaire club bug? I was playing a two player game. Either way I was bummed that I didn't get to enter my name into the billionaires club.


Thanks Craig. I hate those machines with the long habitrail auto-launchers.

I'll try to look at RBION this week.

The BoP reset does sound like a known bug with rev. L-7 software IIRC.

Good to hear that things went well otherwise!
Jon S.
user 72344872
Oklahoma City, OK
Post #: 8
Great time Saturday, a few more things:

Pinball Magic: The ball stuck in the trunk for well over a minute without a ball search initiating. It finally kicked out a minute or two after we walked away.

NASCAR: The scoop under the pop-up car failed to register a few times on an early game. Fine during later games so it looks intermittent.

GNR: Still had a couple of ball launch roll backs. Always recovered.

CFTBL: Missing gate out of shooter lane. Some shots can end up back in shooter lane. Two FILM lamps out. Insert window lip tends to change ball direction (not sure if anything can be done about that). Play field may tilt a little (to the right I think), Craig may remember.
Shawn L.
alveolus
Group Organizer
Oklahoma City, OK
Post #: 106
Great time Saturday, a few more things:

Pinball Magic: The ball stuck in the trunk for well over a minute without a ball search initiating. It finally kicked out a minute or two after we walked away.

NASCAR: The scoop under the pop-up car failed to register a few times on an early game. Fine during later games so it looks intermittent.

GNR: Still had a couple of ball launch roll backs. Always recovered.

CFTBL: Missing gate out of shooter lane. Some shots can end up back in shooter lane. Two FILM lamps out. Insert window lip tends to change ball direction (not sure if anything can be done about that). Play field may tilt a little (to the right I think), Craig may remember.

Thanks for the report. I have looked at that trunk before. Bit of a puzzler. All of the optos seem to register fine. Maybe a Capcom quirk.

The scoop switch in NASCAR takes a beating. I will adjust it again.

I'm not sure if the shooter lane ball gate for Creature is available for purchase. I may have to fabricate one. The window can probably be adjusted a bit but will likely still affect a slow-rolling ball.
Shawn L.
alveolus
Group Organizer
Oklahoma City, OK
Post #: 110
Spent a couple hours at SS working on machines. I had to pull the driver board out of Jackbot as the 12v and 20v were out. I will see if I can get it working.

Ripley's just had a bunch of burned out bulbs on the lower playfield which I replaced. GNR was not launching balls properly which turned out to be a loose bracket on the auto launcher. A13 was launching balls just fine, but I'll keep checking on it.

I didn't have time for the rest, so ill try to get to those next time.
Shawn L.
alveolus
Group Organizer
Oklahoma City, OK
Post #: 115
Problem one: Road Show- Start City kickout not working.
Easy one. A wire was broken off one of the coil lugs. Soldered it back on and it worked normally.

Problem two: Road Show: Lock kickout not working.
Not quite as simple. In solenoid test, I could hear the lock kickout coil firing, so why wasn't the ball coming out? I checked under the playfield and there was another coil in the lock trough which would release the balls to the kickout position. This coil, the "Lock-up pin", did not fire in diagnostics. I checked the voltage; one lug measured the expected 50v, the other, nada. This is usually a broken coil winding. I peeled back the coil wrapper and voila'! The wire was indeed broken(see photo). I unwrapped the wire one revolution, sanded off the insulation, and resoldered it to the lug. Now the lock kickout was working properly.
Craig A.
caker137
Stillwater, OK
Post #: 76
Hey Shawn,

Any interesting repairs lately? Did you get a chance to diagnose the JD left flippers issue?

Craig
Shawn L.
alveolus
Group Organizer
Oklahoma City, OK
Post #: 117
Hey Shawn,

Any interesting repairs lately? Did you get a chance to diagnose the JD left flippers issue?

Craig
Unfortunately, my work schedule has not been allowing me to get out to the arcade. I hope to get in some repair time in the next week or so. I will have quite a bit more time in August to catch up. Bear with me and please keep the problem reports coming!
Craig A.
caker137
Stillwater, OK
Post #: 79
Issues from today:

AF - was stuck in ball search for a while; not sure if a ball was stuck or not (I wasn't playing at the time). I seemed to fix itself later In the day

JY - coins were registering credits intermittently, then not at all

AC/DC - the spring thing near the pops exit was misadjusted; trapping balls

PM - the display mount has shifted leaving the DMD falling low on one side

Craig
Shawn L.
alveolus
Group Organizer
Oklahoma City, OK
Post #: 122
Finally had some time to do a couple repairs this week.

Problem one: Judge Dredd left flipper stuck in up position.
It was obviously not a mechanical problem as it would occur only during a game and drop at the end of a ball. I went into switch levels test and the flipper switch was showing closed without pressing the button. So, I had a look at the left flipper switch and saw something new:


So this is an aftermarket flipper board that uses a magnet sensor to detect the flipper button press. I had no idea how it worked so I had to contact the manufacturer. I learned that the position of the magnet determines the sensitivity. The magnet is attached to the metal "spring" by only its magnetism, which allows it to slide around. Anyway, the little rectangular magnet had moved into the closed position. The green LEDs indicate the switch is closed. I slid the magnet around until the LEDs went off then the flipper dropped back down and worked properly, although it again quickly moved out of position. I readjusted it and taped it down but I'm not sure if it will hold. I'm not sure I like the design.

Problem two: Judge Dredd not detecting balls in trough.
The ball trough in JD uses optos switches to detect the balls. 2 of the trough switches were not registering in switch test. Most commonly the infrared transmitter is what goes bad. I used an incandescent flashlight to simulate the transmitter and the suspect switches registered. To confirm that the transmitters are bad, you can use a digital camera which can "see" the IR beam.


I replaced the 2 bad emitters and the trough was working normally. Here is the board after replacing the emitters:

Leslie P.
user 90125672
Edmond, OK
Post #: 20
Shawn:
Went back to Sling Shots on Saturday after eating dinner and played several games. The Shadow was having a major problem. Plastic artwork in upper area by skill shot is broken in two, the ball had gone under the plastic and was stuck. I believe that piece will have to be replaced, unless you have some really good glue! You probably already know but Creature from Black Lagoon is having problems with plunger shooting ball up ramp. Spring on ramp seemed to be preventing ball to launch, or spring may be damaged on plunger?? Also, Safe House on 24 was not recognizing being hit by ball when in "Go to Safe House Mode", and no it was not just me that had the same problem! lol

Thanks,
Leslie
Powered by mvnForum

Our Sponsors

People in this
Meetup are also in:

Sign up

Meetup members, Log in

By clicking "Sign up" or "Sign up using Facebook", you confirm that you accept our Terms of Service & Privacy Policy