WordPress Melbourne User Group Message Board Troubleshooting › Backup Buddy help!!

Backup Buddy help!!

Kim
user 77490082
Melbourne, AU
Post #: 3
Hi guys,
I need help with backup buddy if anyone can help me?? I have 2 sites, the smaller and newer one it works on no probe. The older and bigger blog is having problems, i can do a database backup but when i try a full backup its timing out. My brother hosts it for me and he said all the permissions etc are fine... cant figure out the prob...? (I'm not very techy, not sure what im doing!)
Thanks :)
Anthony H.
maddisondesigns
Melbourne, AU
Post #: 1
You could try adding a php.ini file to your /wp-admin folder. In this file, add the following line:
max_execution_time = 600;

The max_execution_time is how long a process can run before being killed off. This solution may or may not work, it all depends on your host. Some hosts will allow changes via this php file, others will simply ignore them.

Give it a go and see if that helps.
Damien E.
user 78468282
Melbourne, AU
Post #: 1
Also you could check and see if it has actually made the backup. I often have backup buddy getting stuck in a loop but then when I go back to the backups page it has actually finished the backup successfully.

I've had quite a few annoying issues with that plugin!
Tim O.
memeLab
Melbourne, AU
Post #: 1
A couple of things to check:


  • +1 for Damiens suggestion - this is common! You can go BB > Backup and click the little 'refresh' icon to check whether a backup was successful. (similar situation for offsite transfers if its relevant, btw)
  • can you successfully doa DB only backup?
  • how big is big? are we talking 100mb or 1gb? If you're looking at 1gb, maybe getting someone to setup a CDN to seperate out your media might be an option.
  • go to the Backup Buddy> Server Information, see if there are any red flags / warnings there. There's also a link to phpinfo if you need the full lowdown on your php configuration.
  • Are you seeing a message about http loopback connections? if so, you may be experiencing endless ping, which you could fix with the alternate cron setting in wp-config.php
  • Caching plugins may cause issues, too (though I haven't experienced this). Try deactivating your caching plugin if you use one.
  • (its unclear whether both these site are hosted on the same server. Note that loopback connections don't always work if your site is in a subdomain (eg subdomain.mysite.com) fix this with alternate cron as above.
  • If its allowed, BB will auto set max execution time to 7200.

The fellas in the ithemes support forum are pretty good - if your license is current - they'll deal with you directly!
For the niggles I've had with BB, it's still been 100% worthwhile persisting with it! Best wishes, Tim
Kim
user 77490082
Melbourne, AU
Post #: 4
Hi Guys,
Thanks so much for your suggestions! I asked to change the time limit, but the server wont allow changes to the php.ini file, which is set to 30. There are a few warnings on the server information section. I'm switching from one server to another, hence the backup.
I'll check with ithemes and see if they can help, thanks again!!
Kim
user 77490082
Melbourne, AU
Post #: 5
Tim you were right, I posted on the forum with a copy of the run script and the backup buddy guys got straight back to me and sorted through the lines to find the problem smile
Tim O.
memeLab
Melbourne, AU
Post #: 3
glad to hear it! when buying hosting for myself or a client, the BB server requirements are the top of my list:

* fastcgi or suPHP so that the apache runs as the user
* sufficient memory (ideally 128mb+)
* commandline zip
* loopback connections enabled

best wishes!
Powered by mvnForum

Our Sponsors

People in this
Meetup are also in:

Sign up

Meetup members, Log in

By clicking "Sign up" or "Sign up using Facebook", you confirm that you accept our Terms of Service & Privacy Policy