addressalign-toparrow-leftarrow-rightbackbellblockcalendarcameraccwcheckchevron-downchevron-leftchevron-rightchevron-small-downchevron-small-leftchevron-small-rightchevron-small-upchevron-upcircle-with-checkcircle-with-crosscircle-with-pluscrossdots-three-verticaleditemptyheartexporteye-with-lineeyefacebookfolderfullheartglobegmailgooglegroupsimageimagesinstagramlinklocation-pinm-swarmSearchmailmessagesminusmoremuplabelShape 3 + Rectangle 1outlookpersonJoin Group on CardStartprice-ribbonImported LayersImported LayersImported Layersshieldstartickettrashtriangle-downtriangle-uptwitteruseryahoo

London Scala Users' Group Message Board London Scala User Group Discussion Forum › Compiled with Scala 2.8.1 is incompatible with Eclipse workspace?

Compiled with Scala 2.8.1 is incompatible with Eclipse workspace?

Bryan
binarytemple
London, GB
Post #: 1
Scala 2.8.1 has got a bug whereby the class files it generates are broken.

They are rejected by Eclipse, disabling auto-completion for the current project and turning your workspace red.

Thus you cannot use your Scala library in Java or at least via Eclipse (which 99% of Java developers use).

Here's the original Eclipse bug report

This is the kind of stuff that makes me wonder if I'm heading in right direction.

scala bug tracking system
Powered by mvnForum

Our Sponsors

  • Scala Dojo

    Web site for monthly Scala Dojo

  • Scala Jobs

    Google Group of Scala Jobs in the London Area

  • _.underscore

    Scala consultants, trainers, and developers, based in London, UK

  • Springer

    Help and supporters of the monthly dojo

  • Skills Matter

    Provide the venue for many of our meetings.

People in this
Meetup are also in:

Sign up

Meetup members, Log in

By clicking "Sign up" or "Sign up using Facebook", you confirm that you accept our Terms of Service & Privacy Policy