addressalign-toparrow-leftarrow-rightbackbellblockcalendarcameraccwchatcheckchevron-downchevron-leftchevron-rightchevron-small-downchevron-small-leftchevron-small-rightchevron-small-upchevron-upcircle-with-crosscrosseditemptyheartfacebookfolderfullheartglobegmailgoogleimagesinstagramlinklocation-pinmagnifying-glassmailminusmoremuplabelShape 3 + Rectangle 1outlookpersonplusprice-ribbonImported LayersImported LayersImported Layersshieldstartrashtriangle-downtriangle-uptwitteruseryahoo

RE: [web-99] Need Advice About Wordpress Install

From: John A.
Sent on: Thursday, February 2, 2012 8:14 PM

No good options here. Running old versions of WP is an invitation to be hacked.

 

Sound like you will have to move to Windows to have a functioning if hamstrung site.

 

 

John Allen

www.marketing-ontheweb.com

 

 

From: [address removed] [mailto:[address removed]] On Behalf Of Jonathan Wright
Sent: Thursday, February 02,[masked]:53 PM
To: [address removed]
Subject: [web-99] Need Advice About Wordpress Install

 

Hi Web Developers,

I am trying to get Wordpress up and running on a client's server.
My client's web host is Brinkster, which is a less than perfect host for Wordpress,
but I won't delve into why I am stuck with them.

I have run through the Wordpress installation a dozen times, so I have no issues with WP per say. But Brinkster does not have a one-click install for Wordpress.

On my first install, my issues were file permissions and permalinks. Then WP asked me to update to WP 3.3.1. Then everything crashed : (
Brinkster support recommended that if I ever update Wordpress, I'll need to do it manually. (sigh)

I then had Brinkster move my client from Windows / IIS 6 over to Linux / Apache 2. (Filezilla uses Linux and I like Filezilla, plus I get Apache's mod URL rewrite for permalinks )

To make a long story short, on my 4th or 5th run of manually installing WP, I received this message:

"Your server is running PHP version 5.2.3 but WordPress 3.3.1 requires at least 5.2.4"

When I asked Brinkster, they said "Well we do not have a Linux server with that PHP version, but we could move you to a Windows Server." Been there done that.

So finally, here are my 2 choices:

1. Continue to enjoy the benefits of a Linux / Apache server, but run an older version of Wordpress (WP says earlier releases are less safe)
2. Or move to a Windows / IIS 6 server, and lose the benefit of Apache goodies like pretty permlinks, .htaccess files

Either way, I will probably have to update Wordpress manually every time a new version comes out.

Which option do you think I should go with, 1 or 2?

Thanks for your input.
Jonathan Wright






 




--
Please Note: If you hit "REPLY", your message will be sent to everyone on this mailing list ([address removed])
This message was sent by Jonathan Wright ([address removed]) from North Alabama Web Developers.
To learn more about Jonathan Wright, visit his/her member profile
Set my mailing list to email me As they are sent | In one daily email | Don't send me mailing list messages

Meetup, PO Box 4668 #37895 New York, New York[masked] | [address removed]

Our Sponsors

  • DealNews.com

    DealNews.com provides lunch and meeting space for most NAWD Meetups.

  • JetBrains

    Free Personal License of PhpStorm or any other JetBrains IDE.

People in this
Meetup are also in:

Sign up

Meetup members, Log in

By clicking "Sign up" or "Sign up using Facebook", you confirm that you accept our Terms of Service & Privacy Policy