addressalign-toparrow-leftarrow-rightbackbellblockcalendarcameraccwcheckchevron-downchevron-leftchevron-rightchevron-small-downchevron-small-leftchevron-small-rightchevron-small-upchevron-upcircle-with-checkcircle-with-crosscircle-with-pluscontroller-playcrossdots-three-verticaleditemptyheartexporteye-with-lineeyefacebookfolderfullheartglobegmailgooglegroupshelp-with-circleimageimagesinstagramFill 1launch-new-window--smalllight-bulblinklocation-pinm-swarmSearchmailmessagesminusmoremuplabelShape 3 + Rectangle 1ShapeoutlookpersonJoin Group on CardStartprice-ribbonprintShapeShapeShapeShapeImported LayersImported LayersImported Layersshieldstartickettrashtriangle-downtriangle-uptwitteruserwarningyahoo

The Singapore Linux Meetup Group Message Board › Needing your advise on logging in shared filesystems

Needing your advise on logging in shared filesystems

Apollo
user 8061713
Singapore, SG
Post #: 1
Fellows,

I can't get over this problem. Even the our rh support has not replied back to me yet nor given me other alternatives, therefore, i don't know if this can be solved by just changing high-level configuration in the system.

It's the /dev/log socket...

I got two ftp linux boxes, with home users chrooted to their home directories which are mounted by both servers through NFS. There is a load balancer which designates where the user is logged whenever he/she initiates an SFTP session.

Now comes the logging...

To log the sftp sessions for the jailed users, I did the following:
1. add a new socket in /etc/sysconfig/syslog.
SYSLOGD_OPTIONS="-m 0 -a /stftp/sftplog.socket"
2. restart syslog
3. create a hardlink from the users home to the new socket
mkdir /stftp/user1/dev
ln /stftp/sftplog.socket /stftp/user1/dev/log

This works for the first server. But when I go to the next server, I could not create a hardlink named
/stftp/user1/dev/log anymore because the hardlink is already there.

I also tried to change the default /dev/log socket in /etc/sysconfig/syslog
SYSLOGD_OPTIONS="-m 0 -p /dev/newlog"

However, even after reboot, the system still writes to /dev/log.

Is there a way, we can change the system to write to a custom-named log other than /dev/log ?

I'd appreciate for any suggestions you might have.

Best regards,
apollo

Powered by mvnForum

People in this
Meetup are also in:

Sign up

Meetup members, Log in

By clicking "Sign up" or "Sign up using Facebook", you confirm that you accept our Terms of Service & Privacy Policy